Июнь 2022
Пн Вт Ср Чт Пт Сб Вс
 12345
6789101112
13141516171819
20212223242526
27282930  

cisco radius vrf

Часто сталкиваюсь в последнее время с настройкой аутентификации и авторизации cisco роутерами и свичами на выделенном mgmt порту устройства, поэтому добавлю тут шпаргалку по минимальной настройке:
interface GigabitEthernet0
 vrf forwarding Mgmt-intf
 ip address 10.10.99.22 255.255.255.0
!
ip route vrf Mgmt-intf 0.0.0.0 0.0.0.0 10.10.99.1
!
!
radius-server attribute 6 on-for-login-auth
radius-server attribute 6 support-multiple
radius-server attribute 8 include-in-access-req
radius-server attribute 25 access-request include
radius-server attribute 31 send nas-port-detail
radius-server dead-criteria time 30 tries 3
!

radius server NPS1
 address ipv4 10.10.97.100 auth-port 1812 acct-port 1813
 timeout 2
 retransmit 2
 key 7 ****
!

aaa new-model
!
aaa group server radius NPS
 server name NPS1
 ip vrf forwarding Mgmt-intf
!
aaa authentication login default local
aaa authentication login vty group NPS local
aaa authorization exec default local
aaa authorization exec vty group NPS local

line vty 0 4
 no password
 authorization exec vty
 logging synchronous
 login authentication vty
 transport input ssh
line vty 5 15
 no password
 authorization exec vty
 logging synchronous
 login authentication vty
 transport input ssh

Cisco

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

All rights reserved, 2019